forked from Drift/pvv-nixos-config
29 lines
583 B
Nix
29 lines
583 B
Nix
{ config, ... }:
|
|
{
|
|
security.acme = {
|
|
acceptTerms = true;
|
|
defaults.email = "danio@pvv.ntnu.no";
|
|
};
|
|
|
|
services.nginx = {
|
|
enable = true;
|
|
|
|
recommendedTlsSettings = true;
|
|
recommendedProxySettings = true;
|
|
recommendedOptimisation = true;
|
|
recommendedGzipSettings = true;
|
|
|
|
# virtualHosts = {
|
|
# "www.pvv.ntnu.no" = {
|
|
# forceSSL = true;
|
|
|
|
# locations = {
|
|
# "/pvv" = {
|
|
# proxyPass = "http://localhost:${config.services.mediawiki.virtualHost.listen.pvv.port}";
|
|
# };
|
|
# };
|
|
# };
|
|
# };
|
|
};
|
|
}
|