fermi/modules/shared.nix

45 lines
1002 B
Nix

{ config, lib, pkgs, clan-core, ... }:
{
imports = [
# Enables the OpenSSH server for remote access
clan-core.clanModules.sshd
# Set a root password
clan-core.clanModules.root-password
clan-core.clanModules.user-password
clan-core.clanModules.state-version
# users
../users
];
# Locale service discovery and mDNS
services.avahi.enable = true;
# generate a random password for our user below
# can be read using `clan secrets get <machine-name>-user-password` command
clan.user-password.user = "user";
users.users.user = {
isNormalUser = true;
extraGroups = [
"wheel"
"networkmanager"
"video"
"input"
];
uid = 1000;
openssh.authorizedKeys.keys = config.users.users.root.openssh.authorizedKeys.keys;
};
environment.systemPackages = [
pkgs.ddrescue
pkgs.gptfdisk
pkgs.ms-sys
pkgs.nvme-cli
pkgs.parted
pkgs.pciutils
pkgs.smartmontools
pkgs.testdisk
pkgs.usbutils
];
}