mirror of
https://git.feal.no/felixalb/nixos-config.git
synced 2024-12-22 04:07:28 +01:00
54 lines
1.4 KiB
Nix
54 lines
1.4 KiB
Nix
{ config, lib, pkgs, modulesPath, ... }:
|
|
|
|
{
|
|
imports =
|
|
[ (modulesPath + "/installer/scan/not-detected.nix")
|
|
];
|
|
|
|
boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
|
|
boot.initrd.kernelModules = [ ];
|
|
boot.kernelModules = [ "kvm-amd" ];
|
|
boot.extraModulePackages = [ ];
|
|
|
|
boot.kernel.sysctl = {
|
|
"vm.max_map_count" = 16777216;
|
|
# "fs.file-max" = 524288;
|
|
};
|
|
|
|
fileSystems."/" =
|
|
{ device = "/dev/disk/by-uuid/60a70caf-ca37-488d-8c2a-98a7e9b67d84";
|
|
fsType = "btrfs";
|
|
options = [ "subvol=root" ];
|
|
};
|
|
|
|
fileSystems."/nix" =
|
|
{ device = "/dev/disk/by-uuid/60a70caf-ca37-488d-8c2a-98a7e9b67d84";
|
|
fsType = "btrfs";
|
|
options = [ "subvol=nix" ];
|
|
};
|
|
|
|
fileSystems."/home" =
|
|
{ device = "/dev/disk/by-uuid/60a70caf-ca37-488d-8c2a-98a7e9b67d84";
|
|
fsType = "btrfs";
|
|
options = [ "subvol=home" ];
|
|
};
|
|
|
|
fileSystems."/boot" =
|
|
{ device = "/dev/disk/by-uuid/12CE-A600";
|
|
fsType = "vfat";
|
|
options = [ "fmask=0022" "dmask=0022" ];
|
|
};
|
|
|
|
swapDevices = [ {
|
|
device = "/swapfile";
|
|
size = 64*1024;
|
|
} ];
|
|
|
|
networking.useDHCP = lib.mkDefault false;
|
|
# networking.interfaces.enp14s0.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.wlp15s0.useDHCP = lib.mkDefault true;
|
|
|
|
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
|
hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
|
}
|