mirror of
https://git.feal.no/felixalb/nixos-config.git
synced 2024-12-22 04:07:28 +01:00
49 lines
949 B
Nix
49 lines
949 B
Nix
{ config, pkgs, lib, ... }:
|
|
|
|
{
|
|
imports =
|
|
[
|
|
../../base.nix
|
|
../../common/metrics-exporters.nix
|
|
./hardware-configuration.nix
|
|
./desktop.nix
|
|
];
|
|
|
|
networking = {
|
|
hostName = "sisko";
|
|
defaultGateway = "192.168.10.1";
|
|
interfaces.enp14s0 = {
|
|
ipv4 = {
|
|
addresses = [
|
|
{ address = "192.168.10.172"; prefixLength = 24; }
|
|
];
|
|
};
|
|
wakeOnLan.enable = true;
|
|
};
|
|
hostId = "b716d781";
|
|
};
|
|
|
|
hardware.bluetooth.enable = true;
|
|
sops.defaultSopsFile = ../../secrets/sisko/sisko.yaml;
|
|
environment.variables = { EDITOR = "vim"; };
|
|
|
|
programs.gamemode.enable = true;
|
|
programs.steam = {
|
|
enable = true;
|
|
remotePlay.openFirewall = true;
|
|
};
|
|
|
|
nixpkgs.config = {
|
|
allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [
|
|
"copilot.vim"
|
|
"discord"
|
|
"steam"
|
|
"steam-unwrapped"
|
|
"tlclient"
|
|
];
|
|
};
|
|
|
|
system.stateVersion = "24.11";
|
|
}
|
|
|