mirror of
https://git.feal.no/felixalb/nixos-config.git
synced 2024-12-22 04:07:28 +01:00
29 lines
543 B
Nix
29 lines
543 B
Nix
{ config, pkgs, lib, ... }:
|
|
{
|
|
# Boot drives are defined in ./hardware-configuration.nix
|
|
|
|
boot = {
|
|
zfs.extraPools = [ "tank" ];
|
|
supportedFilesystems = [ "zfs" ];
|
|
};
|
|
services.prometheus.exporters.zfs.enable = true;
|
|
|
|
environment.systemPackages = with pkgs; [
|
|
cifs-utils
|
|
zfs
|
|
];
|
|
|
|
fileSystems = {
|
|
"/mnt/feal-syn1/backup" = {
|
|
device = "feal-syn1.home.feal.no:/volume2/backup";
|
|
fsType = "nfs";
|
|
options = [
|
|
"defaults"
|
|
"noatime"
|
|
"rw"
|
|
"nfsvers=3"
|
|
];
|
|
};
|
|
};
|
|
}
|